Default Routing

Default Routing

Default Routing is used on the Stubs, meaning the network devices having only one connection. For example, we have the Internet connection in our house or offices.  This means that all the data from the Internet comes from the ISP or Internet Service Provider to our home or offices.  So we have to configure the default routing on the router in our home or offices, which are connected to internet cable coming from the ISP (Internet Service Provider).

Let’s do this practical configuration. Consider the below topology:

Default-Routing

 

As shown in the above image, the Norman router & Vishal router are connected to each other.  Now we have to configure the interfaces & the default routing

Configuring  interfaces on Vishal Router:

Router> enable

Router# configure terminal

Router(config)# hostname Vishal_Router

Vishal_Router(config)# interface f0/0

Vishal_Router(config-if)# ip address 192.168.10.1  255.255.255.0

Vishal_Router(config-if)# no shutdown

Vishal_Router(config-if)# exit

Vishal_Router(config)# interface s1/0

Vishal_Router(config-if)# ip address 192.168.20.1  255.255.255.0

Vishal_Router(config-if)# clock rate 64000

Vishal_Router(config-if)# no shutdown

Vishal_Router(config-if)# exit

Vishal_Router(config)# do show ip interface brief

(For verifying the IP address assigned to Interface are correct)

Configuring  interfaces on Norman Router:

Router> enable

Router# configure terminal

Router(config)# hostname Norman_Router

Norman_Router(config)# interface  f0/0

Norman_Router(config-if)# ip address 192.168.30.1  255.255.255.0

Norman_Router(config-if)# no shutdown

Norman_Router(config-if)# exit

Norman_Router(config)# interface s1/0

Norman_Router(config-if)# ip address 192.168.20.2  255.255.255.0

Norman_Router(config-if)# clock rate 64000

Norman_Router(config-if)# no shutdown

Norman_Router(config-if)# exit

Norman_Router(config)# do show ip interface brief

(Verifying the interfaces on Norman Router)

Configuring Default routing on Both the Routers

Norman_Router(config)# do show ip route

C    192.168.20.0/24 is directly connected, Serial1/0

C    192.168.30.0/24 is directly connected, FastEthernet0/0

Norman_Router(config)# ip route 0.0.0.0  0.0.0.0  192.168.20.1

(means any ip address & any subnet mask  from Next hop 192.168.20.1)

Norman_Router(config)# do show ip route

C    192.168.20.0/24 is directly connected, Serial1/0

C    192.168.30.0/24 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 192.168.20.1

As shown above the default routing is one type of static routing.  This allows all the ip address. It is Represented by S* in the routing table.

Now configuring on Vishal_Router

Vishal_Router(config)# do show ip route

C    192.168.20.0/24 is directly connected, Serial1/0

C    192.168.10.0/24 is directly connected, FastEthernet0/0

Vishal_Router(config)# ip route 0.0.0.0  0.0.0.0  192.168.20.2

(means any ip address & any subnet mask  from Next hop 192.168.20.2)

Vishal_Router(config)# do show ip route

C    192.168.20.0/24 is directly connected, Serial1/0

C    192.168.10.0/24 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 192.168.20.2

Now Verifying the Connection from 192.168.10.2 Command Prompt

C:\> ping 192.168.30.2

Pinging 192.168.30.2  with 32 bytes of data:

Reply from 192.168.30.2 :bytes=32 time=20ms TTL=254

Reply from 192.168.30.2 :bytes=32 time=20ms TTL=254

Reply from 192.168.30.2 :bytes=32 time=20ms TTL=254

Reply from 192.168.30.2 :bytes=32 time=20ms TTL=254

Ping Statistics for 192.168.30.2 :

Packets: Sent=4, Received=4 & Lost=0 (0% Loss)

Approximate round trip times in milliseconds:

Minimum = 10ms , Maximum = 20ms , Average = 15ms

Read more

    Free Cisco CCNA Study Guide

Search

Shortcodes Ultimate

 
Follow Us
 
BGP