VTP

VTP (VLAN Trunking Protocol)

VTP is VLAN Trunking Protocol. VTP is used to trunk the VLAN in the Server Switch. Assume there is a main switch, Norman_Switch, in Norman Company. It has 24 ports, and 20 ports are assigned to respective VLANs . Norman has recruited new employees as follows:

New Developers: 5

New Marketing People: 4

New Accountants : 4

In total, Norman recruited 13 employees. Now they must be assigned to their respective departments. But Norman_Switch has only 4 ports left in switch, and the requirement of ports is 13. So, Norman had to purchase another 24 port switch. The empty ports will be used in the future. We have to configure the VLANs in the new Switch again, but now, by VTP protocol, the VLAN will be copied to New Switch. Let’s carry out the practical.

Connecting the New Switch To Norman_Switch At the Port F0/24

As shown below

VTP

 

Making the Trunk Port on F0/24 port on both the switches

Norman_Switch(Config)# interface f0/24

Norman_Switch(Config)#exit

Norman_Switch# show vtp status

Norman_Switch(Config-if)# switchport mode trunk

Norman_Switch(Config-if)#exit

Norman_Switch-3

 

Norman_Switch# configure terminal

Norman_Switch(Config)# vtp domain Norman_Company

Norman_Switch(config)# do show vtp status

Norman_Switch-4

 

As shown in the above image, Domain Name is changed to Norman_Company from Null.

Configuring new Switch

Switch> enable

Switch# configure terminal

Switch(Config)# hostname Norman_Switch2

Norman_Switch2(Config)# interface f0/24

Norman_Switch2(Config-if)# switchport mode trunk

Norman_Switch2(Config-if)# exit

Norman_Switch2(Config)# exit

Norman_Switch2# show vtp status

Norman_Switch-5

By default it is in SERVER operating mode making it to Client Mode

Norman_Switch2# configure terminal

Norman_Switch2(Config)# vtp mode client

Norman_Switch2(Config)# vtp domain Norman_Company

Norman_Switch2(Config)# do show vtp status

Norman_Switch-6

Norman_Switch2(Config)# do show vlan

Norman_Switch-7

As you can see, the VLAN is now copied to the New Switch, “Norman_Switch2”. Now we must assign the ports  to respective VLAN’s.

For New Developers: F0/1- F0/5

For New Marketing Persons:F0/6-F0/10

For New Accountant: F0/11-F0/15

Norman_Switch2(Config)# interface range f0/1-5

Norman_Switch2(Config-if)# switchport mode access

Norman_Switch2(Config-if)# switchport access vlan 10

Norman_Switch2(Config-if)# exit

Norman_Switch2(Config)# interface range f0/6-10

Norman_Switch2(Config-if)# switchport mode access

Norman_Switch2(Config-if)# switchport access vlan 20

Norman_Switch2(Config-if)# exit

Norman_Switch2(Config)# interface range f0/11-15

Norman_Switch2(Config-if)# switchport mode access

Norman_Switch2(Config-if)# switchport access vlan 30

Norman_Switch2(Config-if)# exit

Norman_Switch2(Config)# do show vlan

Norman_Switch-8

 

As shown in the above image, the new employees are assigned to respective VLAN’s.

Read more

    Free Cisco CCNA Study Guide

Search

Shortcodes Ultimate

 
Follow Us
 
BGP