CCNA Cheat Sheet

CCNA How-to Commands Cheat Sheet

How to configure Static default route

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)# ip route 0.0.0.0 0.0.0.0 12.12.12.2
! mean all route go to the next hop 12.12.12.2


How to configure RIP

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)# router rip
! start the rip configuration
Router(config-router)# network 192.168.1.0
! rip will advertise all network within 192.168.1.0
Router(config-router)# version 2
! rip will run version 2, version 2 is classless
Router(config-router)# no auto-summary
! rip will not summary the network they have into class A,B, or C class


How to configure EIGRP

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)# router eigrp 10
! start the rip configuration with AS number 10
Router(config-router)# network 10.10.10.0
! eigrp will advertised on interface within 10.10.10.0 network and try look for neighbor in that subnet
Router(config-router)# no auto-summary
! Eigrp will not summary network into class full


How to configure OSPF

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
!router configuration
Router(config)# router ospf 10
! start the rip configuration instance number 10
Router(config-router)# network 10.10.10.0 0.0.0.255 area 10
! ospf will advertise and looking neighbor in that interface, and will join area 10
!
!or using interface configuration
Router(config)#interface fa0/0
Router(config-if)# ip ospf 1 area 10


How to configure RIPNG

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
!router configuration
Router(config)#ipv6 unicast-routing
!activated ipv6 unicast
!go to interface
Router(config)#interface fa0/0
Router(config-if)# ipv6 rip TESTING enable
!configure interface to enable RIP instance TESTING


How to configure OSPFv3

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#ipv6 unicast-routing
!activated ipv6 unicast
Router(config)#ipv6 router ospf 1
!go router configuration to activate ospfv3
Router(config-router)#router-id 1.1.1.1
!configure router id for ospf 1
!go to interface
Router(config)#interface fa0/0
Router(config-if)# ipv6 ospf 1 area 0
!configure interface to enable ospfv3 area 0


How to configure EIGRP IPV6

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#ipv6 unicast-routing
!activated ipv6 unicast
Router(config)#ipv6 router eigrp 1
!go router configuration to activate eigrp with as number 1
Router(config-router)#router-id 1.1.1.1
!configure router id for eigrp 1
Router(config-router)#no shut
!activate eigrp process
!go to interface
Router(config)#interface fa0/0
Router(config-if)# ipv6 eigrp1
!configure interface to enable eigrp with as number 1


How to configure simple Standard Access-list

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#access-list 1 deny 10.10.10.0 0.0.0.255
!deny network 10.10.10.0/24
Router(config)#access-list 1 permit any
!permit any other else
Router(config)#interface fa0/0
!go to interface
Router(config-if)#ip access-group 1 out
!apply access-list for traffic out interface


How to configure Extend Access-list

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#access-list 100 deny tcp 10.10.10.0 0.0.0.255 host 2.2.2.2 eq www
!deny tcp traffic from network 10.10.10.0/24 into host 2.2.2.2 specific http (80) traffic
Router(config)#access-list 100 permit ip any any
!permit any other else
Router(config)#interface fa0/0
!go to interface
Router(config-if)#ip access-group 1 in
!apply access-list for traffic out interface


How to configure static NAT

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#ip nat inside source static 10.10.10.3 12.12.12.3
!nat inside ip 10.10.10.3 into outside ip 12.12.12.3
Router(config)#interface fa0/0
!go to interface
Router(config-if)#ip nat inside
!put command into inside (LAN) interface
Router(config)#interface s0/0
!go to interface
Router(config-if)#ip nat outside
!put command into outside (WAN) interface


How to configure Port Address Translation

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#access-list 7 permit 10.10.10.0 0.0.0.255
!create access-list network we want to translation
Router(config)#ip nat inside source list 7 interface s0/0 overload
!configure PAT on interface s0/0 with source address list 7 (see access-list 7)


How to configure PPP authentication

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#username TESTING password TEST123
!config for PPP username
Router(config)#interface s0/0
!go to the interface that will run PPP
Router(config-if)#encapsulation ppp
!config encapsulation PPP
Router(config-if)#ppp authentication chap
!config authentication type
!config same on the other router


 

How to configure HSRP

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#track interface serial0/0 line protocol
!config WAN interface that we want to track
Router(config)#interface fa0/0
!go to the interface we want run hsrp
Router(config-if)#ip address 10.10.10.1 255.255.255.0
!config ip address for the interface
Router(config-if)#standby 1 ip 10.10.10.254
!config virtual ip for hsrp
Router(config-if)#standby 1 priority 120
!config priority for this hsrp group, higher win
Router(config-if)#standby 1 preempt
!config to preempt when the priority win
Router(config-if)#standby 1 track 1 decrement 30
!track interface on track 1 and decrement 30 if interface is down


How to configure VRRP

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#track interface serial0/0 line protocol
!config WAN interface that we want to track
Router(config)#interface fa0/0
!go to the interface we want run hsrp
Router(config-if)#ip address 10.10.10.1 255.255.255.0
!config ip address for the interface
Router(config-if)#vrrp 1 ip 10.10.10.254
!config virtual ip for vrrp
Router(config-if)#vrrp 1 priority 120
!config priority for this vrrp group, higher win
Router(config-if)#vrrp 1 preempt
!config to preempt when the priority win
Router(config-if)#vrrp 1 track 1 decrement 30
!track interface on track 1 and decrement 30 if interface is down


How to configure GLBP

! go to enable mode
Router>enable
Router#
!
! go to global configuration mode
Router#config t
Router(config)#interface fa0/0
!go to the interface fa0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
!config ip address for the interface
Router(config-if)#glbp 1 ip address 10.10.10.254
!config glbp group 1 with virtual ip

 

 

 

Read more

   CCNA Tutorial

   CCNA Practice Test  

Search

Shortcodes Ultimate

 
Follow Us
 
BGP